where people touched by diabetes help each other.

Hello....we are setting up OpenAPS and looking for a compatible pump at a reasonable price....we have minimed 723 but firmware is ver3.0 and it needs to be 2.4a or older..any help greatly appreciated

Submit